Tech Dreams

Fixing The Error “.NET Runtime version 2.0.50727.3053 – Fatal Execution Engine Error” [.NET]

Microsoft .NET Today when Visual Studio.NET 2008 IDE is launched, the IDE closed automatically after few seconds without any error/warning message. I tried launching it again but the result is same – VS.NET 2008 IDE closes automatically after a glance “Start Page”.

Going through the Windows Event Log revealed an error message with the description

.NET Runtime version 2.0.50727.3053 – Fatal Execution Engine Error (6C8B7706) (80131506)

The exception seems to be not a common one and searching the web revealed only one Microsoft forum post. The Microsoft forum post is unanswered.

I decided to fix the issue by reinstalling the .NET framework. The only entry available in Add/Remove programs was “Microsoft .NET framework 3.5” (surprisingly there were no entries of .NET framework 2.0 & 1.1 even though they are installed on my laptop). I reinstalled .NET framework 3.5 after uninstalling the existing setup.

After the reinstallation I launched VS.NET 2008 IDE and the result is same – It closes automatically after displaying Start Page.

Spending 4 hours on various software reinstalls has not yielded any positive solution. Then I decided to restore my Windows Vista OS to the state it was before the recent Windows Update. With the help of System Restore utility I restored the Windows Vista OS to the state it was 4 days ago and the problem is solved :)

Even though this might not be the right way of fixing the problem, it got a work around solution and able to continue web development. If any of you are facing similar kind of problem, use this solution as your last option. If you find a better solution, please let me know.

21 Comments on Fixing The Error “.NET Runtime version 2.0.50727.3053 – Fatal Execution Engine Error” [.NET]

  1. Julius
    December 20, 2010 at 2:34 pm (9 years ago)

    How to: View SQL Server 2005 setup Log Files” and Starting SQL Server Manually?

    Reply
  2. Sean
    August 12, 2010 at 9:07 pm (9 years ago)

    If your using resharper, delete your suo file and reopen. Problem fixed for me.

    Reply
  3. Zenzer
    February 6, 2010 at 1:01 am (10 years ago)

    Got the same error when loading a solution in VS2005 – after doing a registry clean using ccleaner, as mentioned above. Installed the hotfix Jeroen links to, and that fixed my issue.

    Thanks!

    Reply
  4. Vijay Pandey
    November 9, 2009 at 11:02 am (10 years ago)

    I had the same issue. I uninstalled older .net versions and repaired .net framefork 3.5. It fixed my issue.

    Reply
  5. Tom B
    August 26, 2009 at 9:40 pm (10 years ago)

    963676 did not work for me at first either.

    So then I used a shareware .NET clenup tool to remove all versions of .NET from the server. Started with a clean install of .NET that is working properly and then apply the 963676 patch. I got the cleanup tool from freewaregeeks, reinstalled and it fixed it. I’m hoping 963676 will keep it from breaking again.

    Reply
    • Gopinath
      August 27, 2009 at 10:02 am (10 years ago)

      @Tom B,
      Can you please let us know the shareware tool you are using to remove all version of .NET? It’s very handy to have such a tool as we need to repair corrupted .NET frameworks now and then.

      Reply
  6. Dong Luu
    July 2, 2009 at 9:22 am (10 years ago)

    The patch at this address: http://support.microsoft.com/?kbid=963676 doesn’t fix all issues. After apply this patch my VS 2008 still crash without any message.

    Take a look at Event Viewer, i saw that message:
    .NET Runtime version 2.0.50727.4005 – Fatal Execution Engine Error (7A2E111A)(0)

    Reply
  7. Doug Odegaard
    March 3, 2009 at 4:00 am (11 years ago)

    I had the same thing on a simple website. Uninstalled ReSharper and went back to normal. Then reinstalled and started happening again. Just disabled ReSharper in VS and project reloaded again.

    Reply
  8. Edward Cooke
    November 25, 2008 at 8:38 am (11 years ago)

    I thought I would mention that the SP1 for .NET 3.5 has some pretty big bugs that will kill some apps, including ReSharper. Try googling .net 3.5 sp1 problems. Unfortunately for me, the fix of removing sp1 didn’t work. I ended up removing all traces of .net and installing fresh from .net 1.1 though .net 3.5…no sp1 for me.

    Reply
  9. Brian Jones
    November 10, 2008 at 10:46 pm (11 years ago)

    I have this same error occur for VS-2005 and VS-2008 on Vista, Sever 2003, and Server 2008.

    I think there is a serious bug buried in the .Net XML engine or even below that.

    I am in thr process of making sure that all .NET & VStudio service packs are installed.

    Reply
  10. Diep
    November 7, 2008 at 9:35 pm (11 years ago)

    I had the same problem with my setup running VS 2008 and resharper 4.1. At first I though it was resharper causing the crash so I uninstalled it. That worked for a while then the problem came back. I tried clearing the temporary .NET files and seem to work (for now). Very annoying problem.

    Reply
  11. Gopinath
    October 24, 2008 at 11:48 pm (11 years ago)

    I’m happy with the approach(system restore) I used to solve the problem. That problem never occurred again…

    Reply
  12. Jeroen de Zeeuw
    October 24, 2008 at 11:25 pm (11 years ago)

    That’s what makes this problem so hard to get your head arround :( There’s just to many things that make this problem seem to ‘ disappear’ for a little while.
    I bet, Brendan, if you reinstall this Model View Controller (MvC) beta framework again, it’ll work again for a while ..

    Reply
  13. Rowan Foulds
    October 24, 2008 at 7:58 pm (11 years ago)

    I find deleting the temporary files from C:\Windows\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files works – for a while at least.

    Reply
  14. Brendan Kowitz
    October 23, 2008 at 3:01 am (11 years ago)

    Whenever I go into the designer on an ASPX page VS just vanishes and event log shows this error…

    Uninstalling Mvc Beta seemed to fix things :'(
    Or maybe it’s because I had both an Mvc app and a Web Application in the same solution I don’t know. I hope not.

    Reply
  15. Mikeal
    October 20, 2008 at 11:42 am (11 years ago)

    I have the same issue, running VS 2008 with resharper 4.1. If I disable resharper using the vs add-in manager this does not happen.

    Reply
  16. Gopinath Munisifreddy
    October 19, 2008 at 10:26 pm (11 years ago)

    Jeroen de Zeeuw,
    I use redgate Resharper tool. I downloaded v3.5 of .NET framework from Microsoft web site and installed it.

    Few of my friends on .NET forums also suggested that running “Registry Clean” option of CCleaner application results in this weird behaviour of Visual Studio. If you are using CCleaner application, it is recommended to avoid running registry cleaning option.

    Reply
  17. Jeroen de Zeeuw
    October 19, 2008 at 10:09 pm (11 years ago)

    This issue is driving me crazy! My visual studio crashes at least 20 times a day, since I installed .net 3.5 sp1 + studio 2008 sp1 on both my laptop and desktop client (both dual core / 4 GB machines etc.)
    It seems that Visual Studio get very unstable when working with ‘xml’ based files like resource files, xaml files, xml files, etc.
    Opening one of this files is like a time bomb. Building / Rebuilding with one of these file open, cause also the studio to disappear.

    My event log is full with messages like yours. I was wondering, what kind of third party tools have you got installed? Do you use Resharper?

    I appreciate your hint to reinstall .net stuff, but frankly, I don’t think it’s an acceptable solution, as you would agree with me. I surprised that I can’t really find much about this problem, as I can image that many people suffer from this issue.

    Regards,

    Jeroen de Zeeuw

    Reply

1Pingbacks & Trackbacks on Fixing The Error “.NET Runtime version 2.0.50727.3053 – Fatal Execution Engine Error” [.NET]

  1. .NET Runtime version 2.0.50727.3053 - Fatal Execution Engine Error(7A097706) (80131506) | keyongtech
    January 18, 2009 at 10:56 pm (11 years ago)

    […] find any other way to sort out the issue. You can read more about the solution i adopted over her https://www.techdreams.org/microsoft/…t/370-20080926 Hope this helps you. "Rotem" wrote: > Hello > I have developed a windows […]

    Reply

Leave a reply to Sean

Click here to cancel reply.